Subscribed unsubscribe Subscribe Subscribe

かみぽわーる

kamipo's blog

Redmineのインストール

redmine

REEにRedmineをインストールするときの注意点

  • rack 1.0.1 が必要
  • i18n 0.4.2 が必要
  • rubygems のバージョンが 1.5.0 未満じゃないと動かない
    • REE の rubygems が 1.5.2 なのでバージョンを下げないといけない


以下、Debian squeezeでRedmineを動かすまでの作業ログ。

mkdir -p ~/work
cd ~/work
wget http://rubyenterpriseedition.googlecode.com/files/ruby-enterprise_1.8.7-2011.03_amd64_debian6.0.deb
sudo dpkg -i ruby-enterprise_1.8.7-2011.03_amd64_debian6.0.deb

sudo gem install rubygems-update -v=1.4.2
sudo update_rubygems

sudo gem install rack -v=1.0.1
sudo gem install i18n -v=0.4.2

sudo aptitude install libsqlite3-dev
sudo gem install sqlite3

wget http://rubyforge.org/frs/download.php/74419/redmine-1.1.2.tar.gz
tar zxvf redmine-1.1.2.tar.gz
cd redmine-1.1.2

cat << EOS > config/database.yml
production:
  adapter: sqlite3
  database: db/production.db
EOS

rake config/initializers/session_store.rb
rake db:migrate RAILS_ENV="production"
rake redmine:load_default_data RAILS_ENV="production"

ruby script/server webrick -e production