Subscribed unsubscribe Subscribe Subscribe

かみぽわーる

kamipo's blog

Nokogiriのインストール

ruby ubuntu

Nokogiriをビルドするのにlibxml/parser.hとかlibxslt/xslt.hが必要なのでいつもの方法でどのパッケージに含まれてるのか調べる。

$ apt-file search libxml/parser.h
libxml2-dev: /usr/include/libxml2/libxml/parser.h
lsb-build-desktop3: /usr/include/lsb3/libxml2/libxml/parser.h
$ apt-file search libxslt/xslt.h
libxslt1-dev: /usr/include/libxslt/xslt.h
$ sudo aptitude install libxml2-dev libxslt1-dev

Nokogiriがビルドできるようになる。

$ gem install nokogiri